Forward & Reverse Geocoding

FREEMIUM
Verified
By Geocoding | Updated 17 days ago | Mapping
Popularity

9.9 / 10

Latency

181ms

Service Level

100%

Back to All Discussions

Error: "Endpoint/v1/forward does not exist"

avatar
f.vanwoerden23
a year ago

This might be a very stupid question, but as I’m a first time user of rapidAPI I’m having problems anyway.

When calling the forward endpoint via PHP & Guzzle using the url provided I get a 404 response and the message that the endpoint does not exist.

What am I doing wrong and how can I fix it?

$url = “https://forward-reverse-geocoding.p.rapidapi.com/v1/forward?" . implode(”&", $encodedParameters) . “&country=NL&accept-language=nl&countrycodes=NL&polygon_threshold=0.0”

$client->request(‘POST’, $url, [
‘headers’ => [“x-rapidapi-host” => “forward-reverse-geocoding.p.rapidapi.com”,
“x-rapidapi-key” => “[key]”
],
]);

avatar
f.vanwoerden23 commented a year ago

That works, thank you for the quick help.

avatar
GeocodeSupport commented a year ago

The endpoint only allows GET requests. POST requests are not allowed and will result in a 404 http error.

So please try:

$url = “https://forward-reverse-geocoding.p.rapidapi.com/v1/forward?" . implode(”&", $encodedParameters) . “&country=NL&accept-language=nl&countrycodes=NL&polygon_threshold=0.0”

$client->request(‘GET’, $url, [
‘headers’ => [“x-rapidapi-host” => “forward-reverse-geocoding.p.rapidapi.com”,
“x-rapidapi-key” => “[key]”
],
]);

Join in the discussion - add comment below:

Login / Signup to post new comments
Rating: 3.7 - Votes: 3