Dark Sky

FREEMIUM
Verified
By Dark Sky | Updated a month ago | Weather
Popularity

9.6 / 10

Latency

507ms

Service Level

100%

Back to All Discussions

Any idea why this request in Dark Sky Time Machine gives a 400 error?

avatar
digitalice
2 years ago

General
Status Code: 400
Request URL: https://dark-sky.p.rapidapi.com/{latitude},{longitude},{time}
Request Method: GET

Response Headers
"cache-control": “no-store”
“content-type”: "application/json; charset=utf-8"
“date”: “Sun, 22 Mar 2020 20:03:15 GMT”
“server”: "RapidAPI-1.0.42"
“strict-transport-security”: "max-age=31536000"
“vary”: “Accept-Encoding”
“x-rapidapi-region”: "AWS - us-west-2"
“x-rapidapi-version”: "1.0.42"
“x-ratelimit-requests-limit”: "100"
“x-ratelimit-requests-remaining”: "93"
“x-response-time”: “0.139ms”
“content-length”: "48"
“connection”: “Close”

Response Body
{2 items
"code":400
"error":“Poorly formatted request”
}

avatar
alexwalling commented 2 years ago

Hey there! Looks like it may be an issue with how the request is being formatted? If you reach out to support@rapidapi.com they’d be happy to help!

avatar
Amplus commented 2 years ago

Hello digitalice, I was getting the same error calling the TimeMachine method but when I changed the Time parameter to unix time it works. Maybe it’s an issue with the url format of the datetime param.

avatar
chrismorris426 commented a year ago

On the time Time Machine I had this error when I only provided a date, as in the example. When I gave it a time (T[HH]:[MM]:[SS]) too it worked correctly.

Join in the discussion - add comment below:

Login / Signup to post new comments
Rating: 4.8 - Votes: 6