Blackbox

FREEMIUM
Par CMunroe | Mise à jour לפני 4 ימים | Data
Popularité

9.7 / 10

Latence

159ms

Niveau de service

100%

Health Check

100%

Retour à toutes les discussions

Issue again - Error: Too many request (300.000 limit but API got not even 100.000)

Rapid account: Sharoncreech S Jq 8 Valav SR
sharoncreech-SJq8valavSR
6 महीने पहले

Issue started again today. I got error
’too many request’, but my daily request for API
is not even 100.000. Total API calls 94,094. Quota usage 8.49% (stats show it)
What is wrong here?Api broke my website again.

I have again removed API. It is ridicilous that
i got too many request error. Can you please check out what is wrong?

Thanks

Rapid account: Sharoncreech S Jq 8 Valav SR
sharoncreech-SJq8valavSR Commented 6 महीने पहले

Great but nothing has been still fixed (: . If you send me
email sharoncreechATgmail.com i’ll give you test url on my website where you can
self test it.

Rapid account: C Munroe
CMunroe Commented 6 महीने पहले

Howdy,

Rapid found the issue and stated they have found and implemented a fix. Please double check on your end. Full response below.

Good day and thank you for reaching out.

We have identified an issue with the cache of the proxy you are passing through. Our Engineering team have implemented a solution to address the previously encountered issue. We kindly request you to test the system once more and provide feedback regarding the outcome.

Thank you for your patience.

Rapid account: Sharoncreech S Jq 8 Valav SR
sharoncreech-SJq8valavSR Commented 6 महीने पहले

Can you send me your mail to my mail sharoncreechATgmail.com
Then i can send you code.

As I said yesterday. Everything was working perfectly until
yesterday when problems arose and are still going on.

Here is the code from header that broke website if there is error (as test i have place there IP address 104.244.77.208 instead of $ip ). Here is the problem that
this discussion format code not right way and show it then not 100% correct as it is really coded:

$curl = curl_init();

curl_setopt_array($curl, [
CURLOPT_URL => “https://blackbox.p.rapidapi.com/v2/104.244.77.208”,
CURLOPT_RETURNTRANSFER => true,
CURLOPT_ENCODING => “”,
CURLOPT_MAXREDIRS => 10,
CURLOPT_TIMEOUT => 30,
CURLOPT_HTTP_VERSION => CURL_HTTP_VERSION_1_1,
CURLOPT_CUSTOMREQUEST => “GET”,
CURLOPT_HTTPHEADER => [
“X-RapidAPI-Host: blackbox.p.rapidapi.com”,
“X-RapidAPI-Key: xxxxxxxxxxxxxx”
],
]);

response=curlexec(response = curl_exec(curl);
err=curlerror(err = curl_error(curl);

curl_close($curl);

if ($err) {
echo “cURL Error #:” . $err;
} else {
echo $response;
}

btw

The issue is still same as yesterday. IF i refresh 2x page with code above then everything works fine. 3x, 4x, 5x etccc error message appear {“message”:“Too many requests”}

It started suddenly yesterday and it is for sure something with Rapidapi. Do you have btw something else where you host code and where i can use it? Rapidapi succks.

Rapid account: C Munroe
CMunroe Commented 6 महीने पहले

Still no response.

One thing I might be able to do is look over your code and make the site no hard “stop” if the API doesn’t work. That way it would fail gracefully, and not roughly.

I also looked over your requests again, and I am still not seeing anything indicating that you are being prevented from making further requests. I am unsure what could be causing them to flag your connections as I have someone using much much much more than you are on the same plan.

It is all very confusing to me as of the moment as to why you are having issues.

Rapid account: Sharoncreech S Jq 8 Valav SR
sharoncreech-SJq8valavSR Commented 6 महीने पहले

Thank you. I hope they send an explanation soon.

Rapid account: C Munroe
CMunroe Commented 6 महीने पहले

Just an update, I’ve not heard anything further. Still waiting for initial response.

Rapid account: Sharoncreech S Jq 8 Valav SR
sharoncreech-SJq8valavSR Commented 6 महीने पहले

Im using

[code]
response=curlexec(response = curl_exec(curl);
err=curlerror(err = curl_error(curl);

curl_close($curl);

if ($err) {
echo “cURL Error #:” . $err;
} else {
echo $response;
}
[/code]

Everythihg what i get is:
{“message”:“Too many requests”}

or

[{“ip”:“104.244.77.208”,“error”:null,“asn”:{“name”:“ARACHNITEC”,“number”:6921,“network”:“104.244.77.0”,“cidr”:24},“detection”:{“bogon”:false,“cloud”:false,“hosting”:true,“proxy”:false,“spamhaus”:false,“tor”:true},“suggestion”:“block”}]

when it working

Rapid account: Sharoncreech S Jq 8 Valav SR
sharoncreech-SJq8valavSR Commented 6 महीने पहले

It looks as they started to limit request per second. If i refresh
rsult theb first 2 times it show result. 3, 4 or 5 times
error appear. Not sure of they have issue or changed something
but it is impposible to use API this way.

Rapid account: C Munroe
CMunroe Commented 6 महीने पहले

Already have a request into their support. They keep making changes in the background and not fully letting people know.

Can you send me a copy of the response you are seeing. Make sure to remove your api key and such when you do.

Rapid account: Sharoncreech S Jq 8 Valav SR
sharoncreech-SJq8valavSR Commented 6 महीने पहले

You can see in the stats that the request is far below
what I should have as a user of the Ultra package.

Daily 300,000 for Ultra and I’ve been on or
below 100,000 for months. First, the problem occurred
today and lasted for about 15 minutes, then it occurred
again around 6:30 p.m.

Unfortunately, I had to remove the API again,
because my website broke. Now I don’t even know
what to do.

The API has been inactive for about 2 hours and
if I make a test, the ‘too many request’ error still occurs.
Can you contact them to ask whats going on.

Thanks

Participez à la discussion - ajoutez un commentaire ci-dessous:

Connectez-vous / Inscrivez-vous pour publier de nouveaux commentaires