OpenAPI 1.2

GRATUITO
Por TransLoc | Atualizado 4 months ago | Location
Popularidade

9.9 / 10

Latência

77ms

Nível de serviço

100%

Voltar para todas as discussões

No data - Harvard shuttle - just one route (no data sometimes/large periods, and then it comes back - see example)

V
ventz
4 years ago

Hi,

I noticed for the new shuttle route for Harvard (the 784 memorial drive route), there’s no data coming sometimes (anything from blips, to like this morning - complete outage)

Here’s the API:

curl -s 'https://transloc-api-1-2.p.mashape.com/arrival-estimates.json?agencies=52&callback=call&routes=4010876&stops=4215616' -H 'X-Mashape-Key:*redacted*' -H 'Accept: application/json'

Returned: (note: data is []):

{"rate_limit": 1, "expires_in": 5, "api_latest_version": "1.2", "generated_on": "2018-05-18T15:09:57+00:00", "data": [], "api_version": "1.2"}

Here’s the actual tracker:

https://m.harvard.edu/transit/route?feed=transit-transloc&direction=loop&agency=52&route=4010876

You can see that there is data there for:
(it’s one shuttle)

Agency: 52
Route: 4010876
Stops: 4215616, and 4215074

I have verified that it’s a free route, not over rate limit (checking once per minute), and have verified from other IPs/etc.

Then randomly, it starts working again:

curl -s 'https://transloc-api-1-2.p.mashape.com/arrival-estimates.json?agencies=52&callback=call&routes=4010876&stops=4215616' -H 'X-Mashape-Key:*redacted*' -H 'Accept: application/json'
{"rate_limit": 1, "expires_in": 5, "api_latest_version": "1.2", "generated_on": "2018-05-18T15:18:25+00:00", "data": [{"arrivals": [{"route_id": "4010876", "vehicle_id": "4016853", "arrival_at": "2018-05-18T11:38:40-04:00", "type": "vehicle-based"}, {"route_id": "4010876", "vehicle_id": "4016853", "arrival_at": "2018-05-18T12:12:55-04:00", "type": "vehicle-based"}], "agency_id": "52", "stop_id": "4215616"}], "api_version": "1.2"}

I’ve noticed this multiple times. In the example above:
1.) no data on: 2018-05-18T15:09:57+00:00
2.) working on: 2018-05-18T15:18:25+00:00

Thanks for looking into this.

avatar
jenn14108 commented 4 years ago

I am also getting the same slow , unreliable response for the Harvard HUIT-784 Shuttle. Also, when querying to find the different routes for Harvard, it says that only one route is active although that is clearly false looking at the transloc map (https://harvard.transloc.com/)

Junte-se à discussão - adicione o comentário abaixo:

Efetue login / inscreva-se para postar novos comentários
Avaliação: 3.2 - Votos: 5